Estamos migrando de sistemas de foros, por favor repórtanos cualquier problema a contacto@dragonjar.org, si te llega a tu bandeja de entrada o a spam un correo que te dice que se solicitó el cambio de contraseña, no te alarmes, es un procedimiento normal de la migración, cambia tu contraseña porque no hay compatibilidad en el sistema de cifrado del viejo sistema con el sistema nuevo, por eso debes resetear tu clave con ese enlace.

Codecrypt 1.2 (resistente al criptoanálisis computacional cuántico)

editado septiembre 2013 en Criptografía
Hola

Bueno ahora que ya he llamado vuestra atención...

Me gustaría que me ayudaseis a instalar, en mi Debian 7, este programa (¿aceite de serpiente?),
de código abierto, similar a GnuPG.

Basado en el criptosistema McEliece.

[hide]codecrypt @ e-x-a.org[/hide]

[hide]files/ @ e-x-a.org[/hide]


Compilándolo no parece dar problemas, pero en la instalación si.

Os dejo también el enlace a la tesis de grado medio del autor en
la facultad de matemáticas de Praga para que los curiosos disfruteis.

[hide]http://e-x-a.org/codecrypt/mk_bachelor.pdf[/hide]

Gracias por adelantado




P.D Errores en la instalación:

g++ -DPACKAGE_NAME="codecrypt" -DPACKAGE_TARNAME="codecrypt" -DPACKAGE_VERSION="1.2" -DPACKAGE_STRING="codecrypt 1.2" -DPACKAGE_BUGREPORT="" -DPACKAGE_URL="" -DPACKAGE="codecrypt" -DVERSION="1.2" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=".libs/" -DHAVE_GMP_H=1 -DHAVE_LIBGMP=1 -DHAVE_MEMSET=1 -DHAVE_MKDIR=1 -DHAVE_FCNTL_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDDEF_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_SYS_FILE_H=1 -DHAVE_UNISTD_H=1 -DHAVE__BOOL=1 -I. -I.// -I/usr/local/include -g -O2 -MT src/ccr-ios.o -MD -MP -MF src/.deps/ccr-ios.Tpo -c -o src/ccr-ios.o `test -f 'src/ios.cpp' || echo './'`src/ios.cpp
In file included from src/ios.h:24,
from src/ios.cpp:19:
src/polynomial.h:61: error: ‘vector’ has not been declared
src/polynomial.h:61: error: expected ‘,’ or ‘...’ before ‘<’ token
make: *** [src/ccr-ios.o] Error 1

Comentarios

  • editado 11:13
    Problemas de compilación e instalación resueltos en la versión 1.3...
    Está muy verde todavía, pero parece que promete...
  • Angelm gracias por tu colabiración... es de gran ayuda dejar este tipo de contenidos para que en un futuro, los afectados, por este mismo error puedan solucionarlo.
Accede o Regístrate para comentar.